Some Distributors are unable to login to the HNMyClub mobile App, Herbalife Shop mobile App and MyHerbalife.com
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 13:30 PDT
Investigating
We are currently investigating this issue.
Posted Apr 10, 2024 - 10:42 PDT
This incident affected: HN MyClub.