New Distributors in US are not able to sign up for Online Contract due to sponsor information are not being accepted

Incident Report for Herbalife

Resolved

Resolved at 3/21/2025 6:11 AM PT
Posted Mar 21, 2025 - 06:38 PDT

Update

We are continuing to investigate this issue.
Posted Mar 21, 2025 - 04:43 PDT

Investigating

We are currently investigating this issue.
Posted Mar 21, 2025 - 04:36 PDT
This incident affected: Online Application.