Members are unable to access the MyHerbalife.com and HN MyClub applications.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Dec 09, 2024 - 09:03 PST
Identified
The HL MyClub and Engage Apps are operational now. Online ordering from MyHerbalife is working now too. However, there will be a delay in volume allocation.
Posted Dec 09, 2024 - 07:02 PST
Investigating
We are currently investigating this issue.

Impacted Location: United States, Puerto Rico, Mexico, Chile, Peru, Colombia, Brazil, Korea
Posted Dec 09, 2024 - 05:44 PST
This incident affected: Online Ordering, MyHerbalife, Receipting, Sales/Call Center, and HL MyClub.