Bangalore, India Contact Center is experiencing connectivity issues affecting Members calls.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 03:09 PDT
Investigating
We are troubleshooting the issue with high priority.
Posted Apr 11, 2024 - 02:30 PDT
This incident affected: Sales/Call Center.