Due to Vendor (Hevrat Hashmal) issue, the Tel Aviv, Israel contact center is experiencing an electrical power outage
Incident Report for Herbalife Nutrition
Resolved
The below issue has been resolved
Posted Mar 14, 2024 - 03:58 PDT
Investigating
Due to Vendor (Hevrat Hashmal) issue, the Tel Aviv, Israel contact center is experiencing an electrical power outage
Posted Mar 14, 2024 - 00:37 PDT
This incident affected: Sales/Call Center.