Due to a scheduled change in our systems some Distributors are intermitently unable to access MyHerbalife or HN MyClub
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Mar 09, 2024 - 10:12 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2024 - 09:49 PST
Update
Our technical team is aware of the issue and working with the vendor to resolve the issue
Posted Mar 09, 2024 - 09:43 PST
Update
We are continuing to investigate this issue.
Posted Mar 09, 2024 - 09:10 PST
Update
We are continuing to investigate this issue.
Posted Mar 09, 2024 - 07:38 PST
Investigating
IMPORTANT!

We are sorry to inform you that we are having an intermittent issue affecting HN MyClub and MyHerbalife. Our Developers are already aware of the problem and are working hard to get it fixed as soon as possible. While we're doing everything we can to resolve the issue, you may experience some periodic disruptions or decreased performance. You can review the latest updates on this page. We appreciate your patience and we apologize for any inconvenience caused.
Posted Mar 09, 2024 - 04:59 PST
This incident affected: MyHerbalife, Receipting, Point of Sale (POS), and HN MyClub.