Some new Applicants (Potential Members) in EMEA and APAC are unable to sign up on the OA (Onboarding Application).

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 02:41 PDT

Investigating

We are currently investigating this issue.
Posted Oct 06, 2025 - 01:00 PDT
This incident affected: Online Application.