Members in India are unable to access the Event Management System

Incident Report for Herbalife

Resolved

This issue has been resolved (Time: 2:30 AM PT 4/17/2025).
Posted Apr 17, 2025 - 02:30 PDT

Investigating

We are Currently Investigating the Issue
Posted Apr 16, 2025 - 20:49 PDT
This incident affected: Online Ordering.