Due to vendor (Turk Telecom) issue, Members are unable to reach the Turkish Contact Center

Incident Report for Herbalife

Resolved

Due to vendor (Turk Telecom) issue, Members were unable to reach the Turkish Contact Center.
Vendor has fixed the issue. Resolved time: 12/8/2025 2:56 AM PT
INC28675614
Posted Dec 08, 2025 - 03:20 PST

Investigating

Due to vendor (Turk Telecom) issue, Members are unable to reach the Turkish Contact Center. The issue is being investigated.
Posted Dec 07, 2025 - 23:53 PST
This incident affected: Sales/Call Center.