Engage experiencing issues
Incident Report for Herbalife Nutrition
Resolved
The issue related to Club Credit transactions through the Engage app on HN My Club, where some customers may have received multiple charges on their credit card is now resolved.
Posted May 25, 2023 - 12:24 PDT
Investigating
We are experiencing an issue with Engage that may be causing a credit card transaction error when customers are purchasing club credit on Engage. We're investigating the issue as priority and will keep you posted of our progress.
Posted May 24, 2023 - 14:39 PDT
This incident affected: HN MyClub.