Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 11, 2025 - 18:00 PST
Update
System maintenance affecting some Member facing applications is planned starting on Saturday, January 11TH at 6:00 PM PT and is expected to conclude on Saturday, January 11th at 11:59 PM PT. The affected applications will be unavailable globally during the maintenance period.
Posted Jan 03, 2025 - 15:51 PST
Scheduled
The affected applications will be unavailable globally during the maintenance period.
Posted Jan 03, 2025 - 15:44 PST
This scheduled maintenance affects: Account Login, Online Ordering, MyHerbalife, Online Application, Receipting, Point of Sale (POS), BizWorks Reports, GoHerbalife, HL MyClub, Online Training/HNGrow, and HN Rewards.