There is a delay in volume allocation for Retail/Club Sales for US and India
Incident Report for Herbalife Nutrition
Resolved
The issue has been resolved and backlog of orders processed.
Posted Feb 29, 2024 - 16:45 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 29, 2024 - 16:44 PST
Monitoring
A fix has been implemented and we're procesing the orders in the backlog.
Posted Feb 29, 2024 - 14:30 PST
Investigating
There is a delay in volume allocation for Retail/Club Sales for US and India. All the sales are accounted for so there is no loss of sales. We will allocate all the volume once we resolve the issue.
Posted Feb 29, 2024 - 06:38 PST
This incident affected: Receipting and BizWorks Reports.