Members from Armenia, Azerbaijan, Uzbekistan, Cyprus and Baltic countries are unable to place the orders through myfiluet.com website
Incident Report for Herbalife Nutrition
Resolved
The myfiluet.com ordering channel is available for Armenia, Azerbaijan, Uzbekistan, Cyprus and Baltic countries
Posted Jan 17, 2022 - 07:15 PST
Investigating
We are currently investigating this issue.
Posted Jan 17, 2022 - 03:57 PST
This incident affected: Online Application.