MyHerbalife was temporarily unavailable
Incident Report for Herbalife Nutrition
Resolved
MyHerbalife.com is currently working as normal
Posted Jan 12, 2022 - 08:23 PST
Monitoring
We experienced a service interruption with MyHerbalife and are investigating the issue. We'll keep you updated.
MyHerbalife is working as normal now but we're still investigating what was the issue
Posted Jan 12, 2022 - 07:48 PST
This incident affected: MyHerbalife.