The Online Contract (OLC) application on MyHerbalife for Kazakhstan is currently under maintenance. The service is temporarily unavailable during this time.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 04:41 PDT

Update

We are continuing to investigate this issue.
Posted Aug 07, 2026 - 02:21 PDT

Update

The Online Contract (OLC) application on MyHerbalife for Kazakhstan is currently under maintenance
Posted Aug 07, 2026 - 02:21 PDT

Investigating

We are currently investigating this issue.
Posted Aug 06, 2026 - 23:06 PDT
This incident affected: Online Application.