Members from Vietnam would not be able to place orders in MyHerbalife.com

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 00:40 PDT

Update

We are continuing to investigate this issue.
Posted Apr 23, 2025 - 22:48 PDT

Update

We are continuing to investigate this issue.
Posted Apr 23, 2025 - 21:03 PDT

Investigating

We are currently investigating this issue.
Posted Apr 23, 2025 - 20:35 PDT
This incident affected: Online Ordering and Receipting.