INC6277911 - Turkey myHerbalife.com website
Incident Report for Herbalife Nutrition
Resolved
Turkey online ordering Issue is resolved
Posted Jan 23, 2023 - 00:07 PST
Update
We are continuing to investigate this issue.
Posted Jan 23, 2023 - 00:05 PST
Update
Turkey online ordering Issue is resolved
Posted Jan 22, 2023 - 23:57 PST
Update
We are continuing to investigate this issue.
Posted Jan 22, 2023 - 23:53 PST
Investigating
Members are not able to place orders in Turkey myHerbalife and also Member Services are not able to place order on behalf of Members. So, Turkey online ordering through myHerbalife site is put on maintenance.
Posted Jan 22, 2023 - 23:46 PST
This incident affected: Online Ordering and MyHerbalife.