Due to Vendor (Premier Energy) issue, Moldova , Chisinau office including surrounding areas are experiencing an electrical power outage and Members are unable to reach the contact center.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 01:35 PDT
Investigating
We are currently investigating this issue.
Posted Jul 25, 2024 - 00:45 PDT
This incident affected: Sales/Call Center.