A dip in the order rate is observed for applications hosted on myHerbalife.com globally.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 04:24 PDT

Investigating

We are currently investigating this issue.
Posted Sep 08, 2025 - 22:50 PDT
This incident affected: MyHerbalife.