We are currently experiencing intermittent issues with processing orders placed on MyHerbalife.com. As a result, there may be delays in order readiness for pickup at pickup locations, as well as potential delays in volume point allocation.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Dec 31, 2024 - 16:14 PST
Update
We are continuing to investigate this issue.
Posted Dec 31, 2024 - 13:39 PST
Investigating
We are currently investigating this issue.
Posted Dec 31, 2024 - 13:39 PST
This incident affected: Online Ordering, MyHerbalife, Point of Sale (POS), and BizWorks Reports.