Bangalore contact center lines have been restored. We are currently addressing audio quality issues and working to resolve them as quickly as possible.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 03:57 PDT

Investigating

We are working on resolving the issue.
Posted Apr 12, 2026 - 22:40 PDT
This incident affected: Sales/Call Center.