We're currently experiencing volume delays on Bizworks because of a maintenance activity.
Incident Report for Herbalife Nutrition
Resolved
Maintenance comleted Bizworks volume is upto date.
Posted Feb 01, 2023 - 04:11 PST
Identified
Multiple SMA jobs affecting Bizworks Volume allocation.
Posted Feb 01, 2023 - 02:52 PST
This incident affected: BizWorks Reports.