Due to vendor (Almaty Zharyk) issue, the Almaty, Kazakhstan Contact center including surrounding areas is experiencing an electrical power outage.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 22:59 PST

Investigating

We are currently investigating this issue.
Posted Nov 06, 2025 - 22:33 PST
This incident affected: Sales/Call Center.