The Global Order rate in myHerbalife.com website dropped to zero
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 06:12 PST
Investigating
We are currently investigating this issue.
Posted Feb 19, 2024 - 02:36 PST
This incident affected: Online Ordering, MyHerbalife, and GOC.