We are continuing to work on a fix for this issue.
Posted May 16, 2026 - 22:58 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 16, 2026 - 22:52 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2026 - 22:18 PDT
This incident affected: Account Login, Online Ordering, MyHerbalife, Online Application, Receipting, Point of Sale (POS), BizWorks Reports, GoHerbalife, Sales/Call Center, HL MyClub, DS - Ecommerce, Online Training/HNGrow, Microsoft Outlook, GOC, Webfax, HN Rewards, Site Builder, Retail Payout, and Pro2Col.