We are experiencing issues with order placing via GOC 2.0 application in Mongolia Sales Centers

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 03:11 PDT

Investigating

The issue is being investigated.
Posted Jun 15, 2025 - 20:47 PDT
This incident affected: GOC.