An intermittent issue is observed with order payment via cards for multiple APAC countries on MyHerbalife.com website.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 04:16 PDT
Investigating
We are currently investigating this issue.
Posted Apr 24, 2024 - 01:27 PDT
This incident affected: MyHerbalife.