Different services are currently experiencing slowness problems

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 13:59 PST

Investigating

We are currently investigating a slowness problem which is affecting different services:
HL MyClub, Engage, MyHerbalife, and DS ecommerce sites.
Posted Feb 28, 2026 - 09:44 PST
This incident affected: Account Login, Online Ordering, MyHerbalife, HL MyClub, and DS - Ecommerce.