Herbalife Nutrition
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Subscribe to Updates
Subscribe
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Global Order dip
Incident Report for
Herbalife
Resolved
This issue has been resolved.
Posted
Mar
06
,
2026
-
20:02
PST
Investigating
An order rate dip was observed for all the applications hosted on myHerbalife.com website globally.
Posted
Mar
06
,
2026
-
20:00
PST
This incident affected: Online Ordering and MyHerbalife.
×
Subscribe to Incident
Subscribe to updates for
Global Order dip
via . You'll receive .