An order rate drop is observed on myHerbalife.com website globally
Incident Report for Herbalife Nutrition
Resolved
This is Resolved
Posted Mar 28, 2024 - 23:10 PDT
Investigating
Investigation is in progress
Posted Mar 28, 2024 - 22:02 PDT
This incident affected: Online Ordering.