DS Commerce and herbalife.com intermittent issues

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 07:07 PDT

Investigating

Customers may experience intermittent issues in Herbalife.com and DS Commerce site. The team is actively working on a resolution.
Posted Sep 14, 2026 - 13:27 PDT
This incident affected: DS - Ecommerce.