Preferred customers & Associates are unable to complete sign-up for Online Contract on India MyHerbalife.com website
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 03:45 PST
Investigating
The issue is being investigated.
Posted Feb 15, 2024 - 01:08 PST
This incident affected: Online Application.