Due to vendor (Mastercard 3D Secure) issue, payment transactions are failing resulting in an order rate dip on MyHerbalife.com Website.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 02:08 PDT

Investigating

We are currently investigating this issue.
Posted Jul 15, 2026 - 01:42 PDT
This incident affected: Online Ordering.