Our technology partner (SalesForce) is experiencing technical issues. This will affect transactional emails, like password resets, order/shipping confirmations and also receipts sending via SMS. The team is working to resolve the issue on priority.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 13:15 PDT

Investigating

We are currently investigating this issue.
Posted Jun 18, 2025 - 18:38 PDT
This incident affected: MyHerbalife.