Members were unable to reach the Croatia Contact Center as the number was inactivated by the Local Telecom Regulators.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 02:45 PDT

Investigating

Members are unable to reach the Croatia Contact Center as the number was inactivated by the Local Telecom Regulators.
Posted Mar 16, 2026 - 02:24 PDT
This incident affected: Sales/Call Center.