Due to an issue with Meta, DS may have issues accessing the contact center using Meta applications. Other contact center methods of communication are fine.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Dec 12, 2024 - 11:55 PST
Investigating
We are currently investigating this issue.
Posted Dec 11, 2024 - 11:37 PST
This incident affected: Sales/Call Center.