Due to a vendor (Kyrgyz Telecom) issue, Members from Kyrgyzstan were unable to reach the contact center using 3rd Party toll-free number

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 03:51 PST

Investigating

We are Currently Investigating the issue.
Posted Feb 25, 2026 - 02:05 PST
This incident affected: Sales/Call Center.