Distributors are not able to place orders in the MyHerbalife.com website globally

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Apr 05, 2026 - 05:07 PDT

Investigating

Users are unable to access some of the SSO applications and an order rate dip is observed for all the applications hosted on myHerbalife.com website globally
Posted Apr 05, 2026 - 04:50 PDT
This incident affected: Online Ordering and MyHerbalife.