Due to the vendor (Intuition) issue, members are unable to access the HL Learn and Learning Center.

Incident Report for Herbalife

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 07:15 PDT

Update

We are continuing to investigate this issue.
Posted Jul 17, 2026 - 01:26 PDT

Investigating

We are currently investigating this issue.
Posted Jul 17, 2026 - 01:19 PDT
This incident affected: Online Training/HNGrow.