Bizworks reports are unavailable for members on myHL and Mobile application.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted May 18, 2022 - 07:13 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 18, 2022 - 05:35 PDT
Identified
The issue has been identified, Data replication is in progress. BizWorks Plus Mobile App and Bizworks Reports on myHerbalife.com is expected to be available by 8:30 AM PT.
Posted May 18, 2022 - 00:39 PDT
Investigating
Bizworks reports are unavailable for members on myHL and Mobile application.
Posted May 18, 2022 - 00:19 PDT
This incident affected: BizWorks Reports.