BizWorks is experiencing delays or slowness
Incident Report for Herbalife Nutrition
Resolved
No delays observed, issue resolved
Posted Jan 27, 2023 - 21:19 PST
Investigating
Some BizWorks are experiencing delays or timeout errors when generating reports and we are investigating the issue. We'll keep you updated.
Posted Jan 27, 2023 - 13:42 PST
This incident affected: BizWorks Reports.