Contact Center Lines are not reachable for South Africa location
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted May 19, 2022 - 08:51 PDT
Investigating
We are currently investigating this issue.
Posted May 19, 2022 - 04:18 PDT
This incident affected: Sales/Call Center.