Members are not able to reach the Madrid, Spain Contact Center due to vendor (Telefonica) issue
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 01:00 PST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2022 - 02:26 PST
This incident affected: Sales/Call Center.