Due to vendor (Avoxi) issue, Members will not be able to reach the Contact Center in Ghana, Accra.
Incident Report for Herbalife Nutrition
Resolved
This issue has been resolved.
Posted Apr 25, 2024 - 19:26 PDT
Investigating
We are troubleshooting the issue on high priority.
Posted Apr 25, 2024 - 04:35 PDT
This incident affected: Sales/Call Center.