Customers are unable to sign up or login to HL1 core commerce site for Spain and United Kingdom.
Incident Report for Herbalife Nutrition
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 08:18 PDT
Investigating
The issue is being Investigated.
Posted Apr 19, 2024 - 00:04 PDT
This incident affected: GoHerbalife.